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Start by creating a Site Definition  
Advanced Local Info 

 
Advanced Remote Info 

 

Requires Manually Typing in 
using the advanced option! 

You can reload your Dynamic 
site from last week! 

Rename appropriately. 

Your user ID and  
private password! 
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Advanced Testing Server Tab 

 
 
 
Use the Test option to confirm your settings work OK?. 
 
 

Create and apply a site template. 
We are going to create a template. Then us ing the template apply it to the home page 
index.html plus 4 more pages: Topic1.html Topic2.html GuestBook.html 
ContactMe.html 
 
 

1. We will start by creating a blank page in our site temp1.html 
2. Open temp1.html in design view. 
3. Centre the cursor using align centre from the properties inspector. 
4. Insert a table 

?? 4 rows 
?? 7 columns  
?? with a width of 700 pixels (check this is pixels and NOT %) 

Note: 
Dreamweaver fills in this field incorrectly. 
Manually type in the details. 
Leave page Blank (None) if not using PHP & MySQL 

Important Select SFTP 
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?? Keep the border thickness set to 1 at this stage even if you require no 
borders in the final template. You will find it impossib le to resize by 
dragging with the mouse with 0 size! 

?? Use the blank defaults for the other settings 

 
 

 
We will now size the table and fill the spaces using image place holders to create the 
outline design.  
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5. The first cell in the first row will be a logo. Place the curser inside the cell then 
select insert > image object > image placeholder or via the common tool bar 
 

.  
 

6. Call this Logo and set the size for the placeholder to 60 x 60 pixels. 
7.  Next we are going to make one large cell spanning the next 6 columns of the 

first row. Click in the second cell of the first row then click and drag to select 
the rest of the cells to the right. 

8. To merge the selected cells, from the top tool bar select: Modify > Table > 
Merge Cells or Right click and select Table > Merge Cells or use the 
keyboard short cut Control + Alt + M  
NB (Keyboard short cut did not function correctly in the B20 lab!) 

9. Insert a placeholder into the merged cells called Banner as before in step 5. 
The height will be the same as before 60 pixels and the width will be a 
maximum of 600 pixels.  
NB: (The default size for a commercial banner is 60x468) 

10. The second row will be populated by 7 placeholders 100 x 33 pixels. 
the first and last cell will have a 1x1 pixel transparent gif resized to 100 x 33 
pixels. This is used for padding and to prevent the cell from collapsing or 
resizing. 

11. All of row 3 is to be merged into one large cell as in step 8 
12. Repeat again merging all of  row 4 into a single cell. 
13. Select row 3 and drag down the page pushing row 4 down ahead of it. Use the 

ruler on the left to gauge  the size, about 500 pixels mark should be OK. 
If you can’t see the ruler you may need to turn it on > via top tool bar View > 
Rulers  
NB: Also option to change measurement formatting. 

14. Remember to save your changes as you go along. Control S or File > Save 
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You should now have something like this. 
 

 
 

Part 2 

Exchanging the placeholders by creating or importing images. 
Having created the page skeleton  we now need to flesh it out by creating the images 
and exchanging them with the placeholders. 
You can use the example graphics in the graphics folder on the L drive in the 
Dynamic folder. However time permitting try making your own in Fireworks. 
 
Items required: 

?? Logo 60x60 
?? Banner 60x600 max or 60x468 commercial size. 

Buttons all 33x100 
1. Home 
2. Guest Book 
3. Topic One  
4. Topic Two 
5. Contact Me 

All sizes in pixels and the working file should be saved as a gif or jpg 
NB Fireworks also saves a png file for updating and edi ting the graphic  latter! 
 
You can use any program of your choice to create the graphics however as 
Dreamweaver is now so tightly integrated with Fireworks it is a simple matter to 
Jump back and forth between the two programs converting the placeholders on route. 

Using Fireworks from Dreamweaver 
Select the first placeholder to convert to a graphic by left clicking on it. Then either 
right click and select Create Image In Fireworks or use the button in the Properties 
Inspector.  
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Editing in Fireworks 

 
 
Jumping into Fireworks like this will create an empty work area the correct size for 
the object. It is now a simply task of filling in the space. Your first attempts will 
probably be quite crude but with a little practice they will soon look very professional. 
 

 
 

This example uses a blue filled 
vector star with a bevel filter 
Applied over the top is  a yellow 
letter K also with a bevel plus a 
shadow filter. 

Click Done to save and 
return to Dreamweaver 

NB The white square with  a red line 
sets the background to transparent! 
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Having created your logo select your choice of optimisation, changing the setting as 
required, then click the Button marked Done  
You will now be asked to save the file twice! 

?? The first save, saves all your layer information as a png file. (This is very 
similar to the Photoshop psd format.) 

?? The second save, saves the file using the setting of your choice as highlighted 
by the box outline.  

For simple shapes and text the gif format will probability give the best results. 
 

Create A Banner 
In a similar vein create a banner! 
 
 
 
 
 
In this example the text was expanded to fill the area, then a drop shadow was applied 
plus a second effect, a  blue outer bevel. All settings use the manufactures defaults. 
Again save into your images folder making the two format saves! 
 

Create the Buttons 
The first and last space in the button row will be blank. For these to spaces will insert 
a blank 1x1 pixel gif. You will find a transparent gif in the Examples Graphics folder. 
To use an existing image. Double click on the placeholder, then use the dropdown 
browser to navigate to the L drive > Short Courses .> Web Page Design Short 
Courses  > Dynamic Web Page Design > Graphics > Buttons. Select the Transparent  
gif and click OK 
Then read the pop up dialog box! 

 
Say Yes and save to your images folder. 
STOP at this point and read the next instruction! 
 
Before clicking on anything set the size of the gif in the Properties Inspector! 
In the properties Inspector type a height of 33 pixels and a width of 100 pixels. 
As the image is only 1x1 pixel it is not so easy to select if you lose the focus. 
 
Copy and paste the first transparent gif into the second blank space on the other side 
of the menu bar deleting the placeholder just prior to the paste! 
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Now create the Buttons graphics 
1. Home 
2. Guest Book 
3. Topic One  
4. Topic Two 
5. Contact Me 

We have several choices for this. We can modify the supplied examples or use the 
button maker to design our own.  
Which ever method you use for your button start with the longest text. Items 2 & 5 
both have 10 characters so start with one of them. 
Tip 
Make notes of the setting for the first button as you go along. Then you can apply the  
same settings to the others for a professional uniform look! 

Using the Option Create Button 

 
 
The wizard will help by stepping you through the process. 

?? First create the UP state, Centre the text in a font and colour of your choice. 
Try a size of 18 or 20 depending on font and weight 
I have applied a drop shadow via the effects dialog box in the Properties 
Inspector and have the background set to transparent. 

?? Next click on the Over tab to create the next state. Use the Copy Up State 
dialog button to copy forward the text from the over graphic. The simplest 
adaptation is just to cycle the text colour for this and the next button state. 
A strong contrasting colour will work well for this 

?? For the Down state I  used a dark colour blend 
?? For the Over While Down a Lighter colour blend 
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?? For the active area I have used the Automatic Default 
?? Clicking Done  steps you back to Fireworks main work area. 
?? Clicking Done  again steps you back to Dreamweaver 
?? Save your graphics to your ‘images folder’. (See screen shot below) 

You only need to save the graphs and do not require the HTML 
?? The button behaviors are applied automatically to create the rollover for you. 
?? Save and test. 

Remember if you are using the testing server option to upload the graphics! 
 

Up Over Down Over & Down 

    
 

 
 
To create the next four buttons again start by editing the place holder in Fireworks. 
But this time just open the first PNG file and copy and past for the next.  
All that is then required is to use the selection tool to display the text and modify for 
the next button. 
Click Done  and Save both files with a suitable name as you return to Dreamweaver. 
Repeat for the rest of the buttons. 
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You should now have something like this? 

  
 
Again Don’t forget to save your work! 
 
If you are going to use any Java scripts for drop down menus or for a Scrolling 
Marquee add them next! 
 
In the bottom row  I am going to add as scrolling marquee, so that is the next task! 
We can hand code the Marquee tag as in week two of the Internet and Web Page 
Design Class or simply use a plug in.  
Find and load by Double Clicking the file (MX16440_Marquee.mxp) 
This extension will be found in the Dreamweaver Extensions folder on the L drive: 
Short Courses > Internet and Web Page Design > All Groups > Dreamweaver Extensions 
 
After installing place the cursor in the bottom row of your table and launch the plugin. 
Complete the dialog box bellow as required. 
 

  
 
Again Don’t forget to save your work! Then test the page in Internet Explorer.  
 
If all works and looks OK we can add an editable region and convert the page to a 
template. 



Dynamic Web Page Design Week 3 Practical 

 11 

Creating an Editable Region 
Place the cursor in the third row . It will almost certainly Align Middle, the default 
setting. 
We will want the content to run down the page so change to Align Top and Left 
 

   
 
Next insert the editable region by selecting from the Common Tool Bar > Templates 
> Editable Region 
 

Dreamweaver  will then inform you it will convert the page, as detailed bellow. 
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Finally name the Editable Region with an appropriate name. 

 
 

 
 
Note: The name must not start with a number! 
 
Finally we can save the page as a Template, call it something like Template1 and 
Dreamweaver will save it to a Template folder with the Extension dwt 
 

 
 

 
 

You are now Ready to create the first five pages for your site! 
As we make the pages we will need to create and add the links to the template page. 
On saving the template all the pages will then be updated with the new hyperlinks. 
You need to make the following pages: 
index.html (All lower case for the server) The Home Page and 
GuestBook.html  / Topic1.html / Topic2.html / ContactMe.html 
 

Use Save and Dreamweaver 
will force you to save the 
page as a Template Save as: Template1 

Click Yes 
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Making your Pages and Updating the Links 
From the Top Tool Bar File > New and select Templates 
 

 
 
Select your Template and click Create to make a new page. 

 
 

Note the name of the 
template used to 
create the page in the 
top right corner! 

This is the only 
part of the page 
that can be 
edited 
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Save the page and 4 more as: 
index.html (All lower case for the server) The Home Page and 
GuestBook.html  / Topic1.html / Topic2.html / ContactMe.html 
 
Having created and saved your five pages close them before you make your 
hyperlinks.  
 
Open your Template page and create the hyperlinks for the buttons you made earlier. 
index.html / GuestBook.html  / Topic1.html / Topic2.html / ContactMe.html 
 
We could have added the hyperlinks as we made the buttons but doing it this way 
we can copy the links direct from the pages eliminating the risk of typing errors. 
 
Finally as you save the template you can update all the pages created with it! 

 
 
And the confirmation Box 

 


